CMSimple - flatfile CMS - Documentation

Flatfile CMS Blog Shop - The Content Management System to take away

information  documentation  downloads  forum
You are here:   Home > Installation > System Requirements
German CMSimple Website English Danish

System Requirements

On the server side

CMSimple 4.6 or higher requires php 5.6 or higher, recommended is php 7.4 or higher. A database is not necessary, all data is stored in .txt,  .htm or .php files.

On the PC

On the PC, a ftp program should be available, to exchange files between the PC and the Internet server and to give read and write access to files and folders on the web server.

On the user side

The user (administrator) should be able to exchange files between PC and Internet server via ftp, and to define the read and write permissions to files and folders on the web server.

« prev top next »

CMSimple News

CMSimple is ready for php 8.2
System Requirements »

CMSimple 5.14 published

2024-01-02

CMSimple 5.14 is more robust against unusual web server configurations, especially for second languages and subsites, as well as when CMSimple is installed in subdirectories.

Download Area »

USBWebserver CMSimple

USBWebserver Screenshot

Test CMSimple offline on your PC, easily with USBWebserver CMSimple.

Templates

Responsive templates are suitable for all visual output devices, from smartphones up to HD screen.

Test the responsive templates of ge-webdesign.de:

Demos & Downloads »

Plugins

With plugins you can extend the functionality of CMSimple. There are Blogs, Comments, Photo Galleries, MultiMedia, MembersArea and much more.

Here you can find demos for most of the available plugins:

Demos & Downloads »

Sponsors Area

This is the place for banners and links to sponsors of CMSimple or any kind of advertising.

Become a CMSimple Sponsor »

You also can support CMSimple by donation:

nach oben