Page 2 of 2

Re: Fehler bei Seitenaufruf

Posted: Wed 17. Jun 2020, 11:21
by Gert
Hallo Sebastian,

naja - wenn man eine Frage stellt, sollte man schon ab und zu mal schauen, ob jemand geantwortet hat ;-)

Zuerst mal: Bei der Brarbeitung des Templates ist einiges schiefgegangen:

https://validator.w3.org/nu/?doc=http%3 ... usen.de%2F

Das Original Template validiert:

https://validator.w3.org/nu/?doc=https% ... _Demoseite

Also solltest Du mal das default Template aktivieren und schauen, ob das Problem weiterhin existiert. Wenn ja, dann muss vor der Seite "Home" noch eine weitere Seite existieren, die aus dm Navigationsmenü entfernt wurde (versteckte Startseite) und die mit einer leeren Überschrift anfängt. Prüfe das mal mit dem Pagemanager ("Seiten" im Admin Menü)

Oder es hat was mit Membersarea zu tun, das hast Du ja auch installiert.

Ausserdem ist Deine template.htm nicht utf-8 codiert, das hat bestimmt was mit Deiner Bearbeitung zu tun. Nach der Bearbeitung muss die template.htm in der Codierung "utf-8 (ohne BOM)" abgespeichert werden. Welchen Editor nutzt Du zur Bearbeitung der template.htm?

Es gibt also eine Menge Baustellen,

Gert

=====================================

PS: Vielleicht ist dieses Template ja besser geeignet für Deine Seite? Einfach das Headerbild austauschen:

https://www.ge-webdesign.de/cmsimpletem ... kMusic2020

Re: Fehler bei Seitenaufruf

Posted: Wed 17. Jun 2020, 12:41
by BastelMachtDas
Hi Gert,

danke für die schnelle Antwort. Ich arbeite mit Notepad++ und habe immer UTF-8 als Kodierung eingestellt. Wenn ich das Standard-Template einstelle, habe ich den gleichen Effekt. Die Fehler habe ich jetzt auch (offline) korrigiert. Ich lade sie gleich hoch.

Re: Fehler bei Seitenaufruf

Posted: Wed 17. Jun 2020, 12:46
by BastelMachtDas
... das Membersarea-Plugin habe ich auch gerade entfernt und habe noch das selbe Problem.

Re: Fehler bei Seitenaufruf

Posted: Wed 17. Jun 2020, 12:48
by BastelMachtDas
... merkwürdig. Nach dem Upload ohne MembersArea-Plugin geht es mit der Home-Seite wieder. Lag scheinbar tatsächlich daran. Danke für deine Hilfe! Ich lasse jetzt nochmal den Validator alles prüfen.

Re: Fehler bei Seitenaufruf

Posted: Wed 17. Jun 2020, 12:50
by BastelMachtDas
Falls du mal im schönen Sondershausen (Thüringen) unterwegs sein solltest, lass es mich bitte wissen. Da gehen wir im Black Sheeps ein schönes Bierchen zischen. :-)

Re: Fehler bei Seitenaufruf

Posted: Wed 17. Jun 2020, 16:51
by Gert
BastelMachtDas wrote:
Wed 17. Jun 2020, 12:50
Falls du mal im schönen Sondershausen (Thüringen) unterwegs sein solltest, lass es mich bitte wissen. Da gehen wir im Black Sheeps ein schönes Bierchen zischen.
Vielen Dank, aber nach Thüringen komme ich eher selten, eher mal ins Erzgebirge, nach Klingenthal, da kommen meine Mundharmonikas her:

https://mundharmonika-berlin.de/ ;)

BastelMachtDas wrote:
Wed 17. Jun 2020, 12:50
Nach dem Upload ohne MembersArea-Plugin geht es mit der Home-Seite wieder.
Dann solltest Du aber auch die Plugin-Aufrufe von MembersArea aus der template.htm entfernen, sonst bricht an dieser Stelle das Template ab:

Code: Select all

<?php echo membersarea_loggedin_hint();?>
Deshalb fehlt auf Deiner Seite der Footer,

Gert

Re: Fehler bei Seitenaufruf

Posted: Wed 17. Jun 2020, 17:00
by BastelMachtDas
Danke für den Tipp. War mir gar nicht aufgefallen... :-/ Ohne Impressum auf jeder Seite kann es teuer werden. Ein Kumpel von mir ist begeisterter Mundharmonikaspieler. Den werde ich mal auf deine Seite hinweisen.